Specopssoft.OSDeploy/ImageServer Did Not Receive a reply within the configured timeout (00:30:00)

When publishing a new driver in Specops Deploy OS you may receive the following error message:

Specopssoft.OSDeploy/ImageServer did not receive a reply within the configured timeout (00:30:00).

This happens when  the publish takes longer than the expected 30 minutes.

  • The fix is quite easy. Browse to the following settings in the registry, and change the timeout value to 3600, instead of 1800.
    • HKLM\SOFTWARE\Specopssoft\Specops Deploy\Admin Tools OS\ConnectionTimeout
    • HKLM\SOFTWARE\Specopssoft\Specops Deploy\Deployment Server\ ConnectionTimeout
    • HKLM\SOFTWARE\Specopssoft\Specops Deploy\Image Server\ ConnectionTimeout

Restart the Deployment Server service, the Image Server service, and the OS Admin Tool. If the publish fails again, increase the value to two hours.

(Last updated on September 10, 2018)

Tags:

darren james

Written by

Darren James

Darren James is a Product Specialist and cyber security expert at Specops Software. He works as a lead IT engineer to help customers reduce costs, improve security and increase productivity. He holds Microsoft certifications within IT Service Management, O365, Enterprise Administrator, Server Administrator and Security. Darren has more than 25 years’ experience working in technical IT roles, centering around Active Directory, IT security, cloud, larger-scale migrations, integrations and identity and success management.

Back to Blog