Upgrade

The information below will help you upgrade to the latest version of Specops Password Policy. For information on upgrading to the latest version of the Client, click here.

Supported upgrade environments

Supported upgrade environments

You can upgrade to the most recent version from Specops Password Policy 4.1 or later. It is strongly recommended that you upgrade all components of Specops Password Policy. It is best practice to upgrade the components in the following order:

  1. Administration Tools
  2. Specops Password Policy Sentinel
  3. Specops Client
Planning an upgrade

Before upgrading, you should:

  1. Read the Specops Password Policy Release Notes. The Release Notes provide a summary of new features and changes since the last release. The Release Notes can help you evaluate whether an upgrade is necessary.
  2. Locate and read the Specops Password Policy Product Documentation.
  3. If you are upgrading to a new major version (for example, from version 5.xx to 6.xx), you will need a new license key before upgrading. Contact your sales representative for more information.
Requirements

To upgrade to the latest version, your organization’s environment must meet the following system requirements:

ItemRequirement
Administration Tools• Windows 8.1 or later
• .Net Framework 4.7.1 or later
• Active Directory and Users and Computers snap-in
• Group Policy Management Console (GPMC)
• (For managing Online Dictionaries only) Internet access to download.specopssoft.com. Note: proxy SSL interception is not supported.
• Windows Powershell 5.1

Specops Password Policy Sentinel• Windows Server 2012 R2 or later
• .Net Framework 4.7.1 or later
• Writable domain controller
Authentication Client• Windows 7 or later
• .Net Framework 3.5 SP1 or later
Specops Arbiter• .Net 4.7.1
• Windows Server 2012 R2 or later

The Specops Setup Assistant will help you meet the system requirements.

Upgrading Specops Password Policy

The Setup Assistant will allow you to upgrade the required components. To start upgrading, follow the below tasks:

  1. Download the Setup Assistant.
  2. Save and Run the Setup Assistant locally to a machine where you administer Group Policy.
    Note: By default the file is extracted to

    C:\temp\SpecopsPasswordPolicy_Setup_[VersionNumber]

  3. Double click SpecopsPasswordPolicy.Setup.exe to launch the Setup Assistant.
  4. To begin, click Start Installation in the Specops Setup Assistant dialog box.

Upgrade the Administration Tools

The Administration Tools are used to configure the central aspects of the solution and enable the creation of Specops Password Policy Settings in Group Policy Objects.

  1. From the Setup Assistant, select Administration Tools.
  2. Click Install.

The Domain Administration tool, Group Policy snap-in extension, and ADUC menu extensions will be updated.

Upgrade the Specops Password Policy Sentinel

The Specops Sentinel ensures that password change requests comply with the Specops Password Policy assigned to the user object through Group Policy.

  1. From Setup Assistant, select Domain Controller Sentinel to install the Sentinel.
  2. You can create a new share or select an existing share. To select an existing share you must copy the Sentinel msi-package into the appropriate share.
    Note: The files can be copied from C:\temp\SpecopsPasswordPolicy_Setup_[VersionNumber]\products\specopspasswordpolicy
  1. Click Select Share.
  2. Browse to the location of the network share, or enter the location of the share name.
    Note: The location of the share name will be a network UNC path.
  1. Click OK.
  2. Select the domain controllers you want to upgrade the Sentinel on, and click Install.
  3. Verify that the Sentinel state for the selected domain controllers has changed to “Installed.”
    Note: If the Sentinel state for the selected domain controllers has changed to “Installed”, it will not be functional until you reboot your domain controllers.

Post-upgrade: You must reboot your domain controllers once you have installed the Sentinel.  Reboot can be scheduled during the regular reboot cycle.

Upgrade the Specops Client

The Client displays the password policy rules when a user fails to meet the policy criteria when changing their password. The Client also notifies users when their passwords are about to expire.

You can automatically upgrade an existing Group Policy Object with Software Installation settings to deploy the Client in your domain.

  1. From the Setup Assistant, select Deploy Specops Password Client using GPSI.
  2. To select the Group Policy Object that will be used to deploy the Client, click Select GPO.
  3. Select an existing GPO from the list.
  4. Click Download… to download the installation files for the Client.
    • In the dialog box, click Download Files.
    • When the dialog box is complete, click OK.
  5. You can create a new share or select an existing share. To select an existing share you must copy the Client Side Extension msi-package into the appropriate share.
    Note: The files can be copied from C:\temp\SpecopsPasswordPolicy_Setup[VersionNumber]\products\specopspasswordpolicy
  1. Click Select Share.
  2. Browse to the location of the network share, or enter the location of the share name.
    Note: It is recommended that you use a Distributed File Share (DFS). If DFS is used with load balancing, verify that the setup files are copied to all servers before proceeding.
  1. To upgrade the packages for x86 and x64 deployments in the selected GPO, click Add Settings.
    Note: The Client Side Extension MSI will be deployed through a computer software installation and may not take effect until the computers have been restarted.

OR

If you are not deploying using GPSI, you can update the Client Side Extension using other deployment tools.

Note: If you are upgrading to the latest version of the Client from version 6.3 or lower, and have previously made configuration changes using the ADMX/ADML template, such as configured the notification interval, you will need to manually migrate your settings. For more information, see Configuring the Client from the Administrative Template. 

Post-upgrade

Congratulations! You have successfully upgraded all of the components. Please complete the following tasks once you have upgraded to the latest version of Specops Password Policy:

  1. Open the Specops Password Policy Domain Administration tool.
    • Enter your new license key if you are upgrading from version 5.0 or lower.
    • Verify that the Password Policy Sentinel State on your domain controllers displays the new version of the Sentinel.
    • Select Language files, and view the status of the files. The status should read OK. If there is a new version available, you will need to click Update Language Files.
  2. If you are using Specops Password Policy and the passphrase feature with Specops Password Reset, users using the mobile application will need to install the latest updates in order to use the passphrase feature.